Neuer Luefter fuer ein NAS vom Typ Buffalo Terastation TS-1.0TGL/R5

Die Terastation bekam ich in einem Zustand, in der sie nicht nutzbar war. D.h. ohne Platten, denn das NAS nutzt 4 SATA Festplatten fuer ein RAID.
Um die Terastation wieder in Betrieb zu nehmen zu koennen und nicht zu viel auszugeben sucht eich also 4 guenstige SATA Platten.
Ich fand in der Bucht einen Haendler, der gebrauchte 40GB 2.5″ Platten fuer 7EUR das Stueck anbot.
Leider war bei der Lieferung (2x Seagate, 1x Fusjitsu und 1x Samsung) eine der 4 Platten defekt. Zum Glueck wurde diese mir kostenfrei aufgetauscht (wieder eine Seagate).

Da die Terastation ohne HD-Einbaurahmen kam, macht ich erstmal ein Sandwich aus den Platten und etwas Pappe:

Platten-Sandwich

Platten-Sandwich

Nun konnte die Terastation schon mal alle 4 Platten erkennen (vorher hatte sie HD 2 angemeckert, weil die nicht startete).
Zum Glueck startete die Terastation noch im Emergency Mode, so dass man nicht vorher erst per TFTP-Server die Firmware haette raufladen muessen.
Wer dazu eine Anleitung sucht, findet diese unter http://ukblog.im-mobility.com/recovering-buffalo-terastation-pro-e06-lost-boot-image-error

Hat man die Terastation im Emergency Mode, kann man „einfach“ den NAS-Updater nutzen, den man bei den Downloads zur Terastation findet.
Dazu geht man auf  http://www.buffalotech.com/support-and-downloads/downloads und sucht nach der Modell-No  TS-1.0TGL/R5

Nochmal zu dem „einfach“🙂 Der Updater wollte bei mir unter Windows 8.1 Update 1 das Update erst nicht machen, weil er immer meldete, dass die Terastation nicht anwortete, obwohl sie vorher schon vom NAS-Navigator gefunden wurde.
Die Loesung war, beiden Programmen die Rechte in der Windows-Firewall fuer den Zugriff zu geben (im privaten Bereich, oeffentlicher ist nicht notwendig).

Genommen habe ich dann fuer das Update die letzte auf der Webseite verfuegbare Version 1.04.0.001 CharFix aus dem Jahr 2007:
http://www.buffalotech.com/support-and-downloads/download/TSPro-1.04-0.01-CharFix.zip

Beim ersten Update-Versuch gab es zwischendrin einen Fehler-Requester, weil das Script nicht sauber lief. Das lag wohl daran, dass die Platten noch nicht von der Terastation formatiert wurden. Nach dem bestaetigen des Requester startete der Updater die Komplett-Formatierung der Platten und tranferrierte dann die Firmware.
Der Transfer ist wichtig, da die Terastation die Firmware und das „Linux“ auf die erste Platte schreibt, weshalb ohne Platten nur der Emergency Modus laeuft.

Ohne DHCP lauft die Terastation als 192.168.11.150, d.h. man muss fuer die erste Konfguration seine Netzwerkkarte am besten in den Bereich bringen.

Anmelden kann man sich dann auf http://192.168.11.150 mit den Stanardwerten einer Neu-Installation der Terastation:
User: admin
Passwort: password

Soweit lief die Terastation nun erstmal an🙂 Aber nach einigen Minuten (oder bei kurzen Tests auch beim Ende des Shutdown) zeigte die den Fehler E11.
Der Fehler E11 weist darauf hin, dass der Luefter nicht laeuft und somit die Kuehlung des NAS nicht gegeben ist😦

Da an der Terastation vorher schon gebastelt wurde, tippte ich als erstes darauf, dass der Stecker nicht auf dem Mainboard steckt.
Nach dem oeffnen zeigte sich aber nun, dass der Stecker steckte….im besten Fall also nur der Luefter tot ist oder die Stromversorgung am Mainboard fuer den Luefter gestorben ist.

Der alte Luefter der Terastation

Der alte Luefter der Terastation

Da ich keinen, wie in der Terrastation genutzten, Luefter im Masse 90x90x25mm da hatte, habe ich erstmal einen 80x80x25mm angesteckt. Beide nutzen 12V und somit lief der 80er Luefeter auch an  – fein🙂

Also ging ich samstags im Laden suchen, weil ich keinen bestellen wollte und fand folgenden Luefter mit den passenden Massen (92x92x25mm passen, aber manchmal sind die Luefter auch mit 90x90x25mm angegeben) und dem passenden 3-Pin Standardstecker

Meine Wahl fuer den neuen Luefter - weil verfuegbar

Meine Wahl fuer den neuen Luefter – weil verfuegbar

Testweise steckte ich den Luefter vor dem Zusammenbau auch an und wie erwartet laeuft auch diesser🙂
Also baute ich alles zusammen (beim Einbau nochmal den Luefter abgesteckt), so dass der Luefter wie vorher die Luft nach aussen pustet.

Der eingebaute Luefter bei noch offenem Gehaeuse - man sieht die blauen Fluegelblaetter

Der eingebaute Luefter bei noch offenem Gehaeuse – man sieht die blauen Fluegelblaetter

und der Luefter wurde auch wieder eingesteckt - man beachte links das schwarze textilumwebte Kabel

und der Luefter wurde auch wieder eingesteckt – man beachte links das schwarze textilumwebte Kabel

Nun nach dem schliessen des Gehaeuses klappte, wie auch vorher, das booten und zugreifen auf die Terastation.

Dass sieht dann z.B. so aus:

System Information meiner Terastation

System Information meiner Terastation

Datumsanzeige der Terastation

Datumsanzeige der Terastation

Netzverbindung der Terastation zu meinem Thinkpad T500 mit 1GBit :-)

Netzverbindung der Terastation zu meinem Thinkpad T500 mit 1GBit🙂

und die Terastation von aussen fertig wieder im Betrieb :-)

und die Terastation von aussen fertig wieder im Betrieb🙂

Trotz der 1GBit-Verbindung kam die Terastation kaum auf 3-6 Megabyte pro Sekunde beim Transfer😦
Wenn man allerdings in der Weboberflaeche im Bereich Netzwerk die Jumbo-Frames aktiviert schafft die Terastation auf einmal 6-11 Megabyte pro Sekunde.
Dies ist zwar fuer eine Gigabit-Verbindung auch nicht viel, aber dies ist wohl der „schwachen“ PowerPC 603e CPU mit 266Mhz, den bei 10 Megabyte pro Sekunde liegt die CPU-Auslastung bei ueber 90%:

Der smb-Daemon hat gut zu arbeiten beim 10MB/sec - evtl. geht per FTP mehr?

Der smb-Daemon hat gut zu arbeiten beim 10MB/sec – evtl. geht per FTP mehr?

Auch per FTP geht nicht mehr durch die Leitung, da die CPU nicht mehr schafft :-(

Auch per FTP geht nicht mehr durch die Leitung, da die CPU nicht mehr schafft😦

Hardware-Infos zu dieser V1 der Terastation Pro (Modell  TS-1.0TGL/R5) gibt es auf:
http://buffalo.nas-central.org/wiki/HardwarePro

Und das Handbuch zur Terastation liegt unter http://www.buffalotech.com/support-and-downloads/download/TeraStation_Pro_Manual_Web.pdf

UPDATE🙂

Auf der europaeischen Seite gabs es ja nur bis Firmware 1.04 – aber es gab auch eine japanische Version 1.12
Der User itimpi hat sich dessen angenommen und eine englische Version 1.12 gebaut in der sogar per Telnet& serielle Schnittstelle ein Zugriff als root moeglich ist🙂

Seine Seite mit den OpenTera Firmwares gibts auf seiner Seite: http://homepage.ntlworld.com/itimpi/telnet.htm
Die Firmware 1.12 fuer meine Terastation lag/liegt auf http://downloads.nas-central.org/Users/itimpi/terapro_112e.zip

Der NAS-Updater muss auch wieder durch die Firewall, so hab ich mal kurz meine ausgemacht. Musste diesmal auch den Gast/oeffentlichen Teil deaktivieren, damit der Updater Daten von der Terastation bekam:

112er Updater hier in englisch - chinesisch ist aber auch dabei :-)

112er Updater hier in englisch – chinesisch ist aber auch dabei🙂

Die englische SysInfo nach dem 112er Update - hat also geklappt :-)

Die englische SysInfo nach dem 112er Update – hat also geklappt🙂

telnet login mit puTTY und dem User myroot

telnet login mit puTTY und dem User myroot

Hier noch die System-/Speicherauslastung im Telnet: top-Ausgabe

Hier noch die System-/Speicherauslastung im Telnet: top-Ausgabe

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s


%d Bloggern gefällt das: